initial commit
[old-projects.git] / muxdaemon / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=4
10
11 config.status: configure
12         dh_testdir
13         # Add here commands to configure the package.
14         ./configure --prefix=/usr \
15         --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
16
17
18 build: build-stamp
19
20 #build-stamp:  config.status
21 build-stamp: 
22         dh_testdir
23
24         # Add here commands to compile the package.
25         #$(MAKE)
26
27         touch build-stamp
28
29 clean:
30         dh_testdir
31         dh_testroot
32         rm -f build-stamp 
33
34         # Add here commands to clean up after the build process.
35         #-$(MAKE) distclean
36         
37         dh_clean
38
39 install: build
40         dh_testdir
41         dh_testroot
42         dh_clean -k
43         dh_installdirs
44
45         # Add here commands to install the package into debian/muxdaemon
46         #$(MAKE) install prefix=$(CURDIR)/debian/muxdaemon/usr rootprefix=$(CURDIR)/debian/muxdaemon
47         dh_install muxdaemon.pl usr/bin
48         
49
50 # Build architecture-independent files here.
51 binary-indep: build install
52         dh_testdir
53         dh_testroot
54 #       dh_installdocs README
55         dh_installexamples muxdaemon.conf
56 #       dh_installman
57 #       dh_installinfo
58         dh_installchangelogs
59         dh_compress
60         dh_fixperms
61         dh_installdeb
62         dh_perl
63         dh_gencontrol
64         dh_md5sums
65         dh_builddeb
66
67 binary: binary-indep
68 .PHONY: build clean binary-indep binary install