cleanup properly on uninstall
[old-projects.git] / depview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=4
10
11 destdir=debian/depview/var/www/depview
12
13 CFLAGS = -Wall -g
14
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16         CFLAGS += -O0
17 else
18         CFLAGS += -O2
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21         INSTALL_PROGRAM += -s
22 endif
23
24 configure: configure-stamp
25 configure-stamp:
26         dh_testdir
27         # Add here commands to configure the package.
28
29         touch configure-stamp
30
31
32 build: build-stamp
33
34 build-stamp: configure-stamp 
35         dh_testdir
36
37         # Add here commands to compile the package.
38         #$(MAKE)
39         #/usr/bin/docbook-to-man debian/depview.sgml > depview.1
40         touch build-stamp
41
42 clean:
43         dh_testdir
44         dh_testroot
45         rm -f build-stamp configure-stamp
46
47         # Add here commands to clean up after the build process.
48         
49         dh_clean
50
51 install: build
52         dh_testdir
53         dh_testroot
54         dh_clean -k
55         dh_installdirs
56
57         # Add here commands to install the package into debian/depview.
58         cp index.php file.php list.php depview.css $(destdir)
59         cp include/header.inc.php include/footer.inc.php $(destdir)/include
60
61 # Build architecture-independent files here.
62 binary-indep: build install
63         dh_testdir
64         dh_testroot
65         dh_installdebconf       
66         dh_installdocs
67         dh_installexamples
68 #       dh_installlogrotate
69 #       dh_installemacsen
70 #       dh_installcron
71 #       dh_installman
72 #       dh_installinfo
73         dh_installchangelogs ChangeLog
74 #       dh_link
75 #       dh_strip
76         dh_compress
77         dh_fixperms
78         dh_installdeb
79 #       dh_perl
80         dh_gencontrol
81         dh_md5sums
82         dh_builddeb
83
84 binary: binary-indep
85 .PHONY: build clean binary-indep binary install configure