0125ffb95d39d9b6261fb14272cee5437c71ca17
[old-projects.git] / depview / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=4
10
11
12
13 CFLAGS = -Wall -g
14
15 ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16         CFLAGS += -O0
17 else
18         CFLAGS += -O2
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21         INSTALL_PROGRAM += -s
22 endif
23
24 configure: configure-stamp
25 configure-stamp:
26         dh_testdir
27         # Add here commands to configure the package.
28
29         touch configure-stamp
30
31
32 build: build-stamp
33
34 build-stamp: configure-stamp 
35         dh_testdir
36
37         # Add here commands to compile the package.
38         #$(MAKE)
39         #/usr/bin/docbook-to-man debian/depview.sgml > depview.1
40         touch build-stamp
41
42 clean:
43         dh_testdir
44         dh_testroot
45         rm -f build-stamp configure-stamp
46
47         # Add here commands to clean up after the build process.
48         #-$(MAKE) clean
49
50         dh_clean
51
52 install: build
53         dh_testdir
54         dh_testroot
55         dh_clean -k
56         dh_installdirs
57
58         # Add here commands to install the package into debian/depview.
59         #$(MAKE) install DESTDIR=$(CURDIR)/debian/depview
60
61         cp *.php debian/depview/var/www/depview
62         cp include/*.php debian/depview/var/www/depview/include
63
64 # Build architecture-independent files here.
65 binary-indep: build install
66         dh_testdir
67         dh_testroot
68         dh_installdebconf       
69         dh_installdocs
70         dh_installexamples
71 #       dh_installmenu
72 #       dh_installlogrotate
73 #       dh_installemacsen
74 #       dh_installpam
75 #       dh_installmime
76 #       dh_installinit
77 #       dh_installcron
78 #       dh_installman
79 #       dh_installinfo
80 #       dh_undocumented
81         dh_installchangelogs ChangeLog
82 #       dh_link
83 #       dh_strip
84         dh_compress
85         dh_fixperms
86 #       dh_makeshlibs
87         dh_installdeb
88 #       dh_perl
89         dh_gencontrol
90         dh_md5sums
91         dh_builddeb
92
93 binary: binary-indep
94 .PHONY: build clean binary-indep binary install configure