a097e7d2c39a5cebcbecb93b76b11c0abc6c27f0
[old-projects.git] / deptrack / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=3
10
11 # These are used for cross-compiling and for saving the configure script
12 # from having to guess our platform (since we know it already)
13 DEB_HOST_GNU_TYPE   ?= $(shell dpkg-architecture -qDEB_HOST_GNU_TYPE)
14 DEB_BUILD_GNU_TYPE  ?= $(shell dpkg-architecture -qDEB_BUILD_GNU_TYPE)
15
16
17 ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
18         CFLAGS += -g
19 endif
20 ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21         INSTALL_PROGRAM += -s
22 endif
23
24 config.status: configure
25         dh_testdir
26         # Add here commands to configure the package.
27         ./configure --host=$(DEB_HOST_GNU_TYPE) --build=$(DEB_BUILD_GNU_TYPE) --prefix=/usr --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
28
29
30 build: build-stamp
31
32 build-stamp:  config.status
33         dh_testdir
34
35         # Add here commands to compile the package.
36         $(MAKE)
37         #/usr/bin/docbook-to-man debian/deptrack.sgml > deptrack.1
38
39         touch build-stamp
40
41 clean:
42         dh_testdir
43         dh_testroot
44         rm -f build-stamp 
45
46         # Add here commands to clean up after the build process.
47         -$(MAKE) distclean
48         -test -r /usr/share/misc/config.sub && \
49           cp -f /usr/share/misc/config.sub config.sub
50         -test -r /usr/share/misc/config.guess && \
51           cp -f /usr/share/misc/config.guess config.guess
52
53
54         dh_clean
55
56 install: build
57         dh_testdir
58         dh_testroot
59         dh_clean -k
60         dh_installdirs
61
62         # Add here commands to install the package into debian/deptrack
63         $(MAKE) install prefix=$(CURDIR)/debian/deptrack/usr
64
65
66 # Build architecture-independent files here.
67 binary-indep: build install
68 # We have nothing to do by default.
69         dh_testdir
70         dh_testroot
71         dh_installdocs
72         dh_installexamples
73         dh_installman
74         dh_installchangelogs ChangeLog 
75         dh_compress
76         dh_fixperms
77         dh_installdeb
78         dh_perl
79         dh_gencontrol
80         dh_md5sums
81         dh_builddeb
82
83 binary: binary-indep 
84 .PHONY: build clean binary-indep binary install