nettoyage
[old-projects.git] / deptrack / debian / rules
1 #!/usr/bin/make -f
2 # Sample debian/rules that uses debhelper.
3 # GNU copyright 1997 to 1999 by Joey Hess.
4
5 # Uncomment this to turn on verbose mode.
6 #export DH_VERBOSE=1
7
8 # This is the debhelper compatibility version to use.
9 export DH_COMPAT=3
10
11 config.status: configure
12         dh_testdir
13         # Add here commands to configure the package.
14         ./configure --prefix=/usr \
15         --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
16
17
18 build: build-stamp
19
20 build-stamp:  config.status
21         dh_testdir
22
23         # Add here commands to compile the package.
24         $(MAKE)
25         #/usr/bin/docbook-to-man debian/deptrack.sgml > deptrack.1
26
27         touch build-stamp
28
29 clean:
30         dh_testdir
31         dh_testroot
32         rm -f build-stamp 
33
34         # Add here commands to clean up after the build process.
35         -$(MAKE) distclean
36
37         dh_clean
38
39 install: build
40         dh_testdir
41         dh_testroot
42         dh_clean -k
43         dh_installdirs
44
45         # Add here commands to install the package into debian/deptrack
46         $(MAKE) install prefix=$(CURDIR)/debian/deptrack/usr
47
48
49 # Build architecture-independent files here.
50 binary-indep: build install
51         dh_testdir
52         dh_testroot
53         dh_installdocs
54         dh_installexamples
55         dh_installman
56         dh_installchangelogs ChangeLog 
57         dh_compress
58         dh_fixperms
59         dh_installdeb
60         dh_perl
61         dh_gencontrol
62         dh_md5sums
63         dh_builddeb
64
65 binary: binary-indep 
66 .PHONY: build clean binary-indep binary install