cleanup properly on uninstall
[old-projects.git] / depview / debian / rules
index 0125ffb..9cca393 100755 (executable)
@@ -8,7 +8,7 @@
 # This is the debhelper compatibility version to use.
 export DH_COMPAT=4
 
-
+destdir=debian/depview/var/www/depview
 
 CFLAGS = -Wall -g
 
@@ -45,8 +45,7 @@ clean:
        rm -f build-stamp configure-stamp
 
        # Add here commands to clean up after the build process.
-       #-$(MAKE) clean
-
+       
        dh_clean
 
 install: build
@@ -56,10 +55,8 @@ install: build
        dh_installdirs
 
        # Add here commands to install the package into debian/depview.
-       #$(MAKE) install DESTDIR=$(CURDIR)/debian/depview
-
-       cp *.php debian/depview/var/www/depview
-       cp include/*.php debian/depview/var/www/depview/include
+       cp index.php file.php list.php depview.css $(destdir)
+       cp include/header.inc.php include/footer.inc.php $(destdir)/include
 
 # Build architecture-independent files here.
 binary-indep: build install
@@ -68,22 +65,16 @@ binary-indep: build install
        dh_installdebconf       
        dh_installdocs
        dh_installexamples
-#      dh_installmenu
 #      dh_installlogrotate
 #      dh_installemacsen
-#      dh_installpam
-#      dh_installmime
-#      dh_installinit
 #      dh_installcron
 #      dh_installman
 #      dh_installinfo
-#      dh_undocumented
        dh_installchangelogs ChangeLog
 #      dh_link
 #      dh_strip
        dh_compress
        dh_fixperms
-#      dh_makeshlibs
        dh_installdeb
 #      dh_perl
        dh_gencontrol