make use of the Common Debian Build System (CDBS)
[old-projects.git] / deptrack / debian / rules
index 8f8f00e..f738c4d 100755 (executable)
@@ -1,66 +1,3 @@
 #!/usr/bin/make -f
-# Sample debian/rules that uses debhelper.
-# GNU copyright 1997 to 1999 by Joey Hess.
-
-# Uncomment this to turn on verbose mode.
-#export DH_VERBOSE=1
-
-# This is the debhelper compatibility version to use.
-export DH_COMPAT=3
-
-config.status: configure
-       dh_testdir
-       # Add here commands to configure the package.
-       ./configure --prefix=/usr \
-       --mandir=\$${prefix}/share/man --infodir=\$${prefix}/share/info
-
-
-build: build-stamp
-
-build-stamp:  config.status
-       dh_testdir
-
-       # Add here commands to compile the package.
-       $(MAKE)
-       #/usr/bin/docbook-to-man debian/deptrack.sgml > deptrack.1
-
-       touch build-stamp
-
-clean:
-       dh_testdir
-       dh_testroot
-       rm -f build-stamp 
-
-       # Add here commands to clean up after the build process.
-       -$(MAKE) distclean
-
-       dh_clean
-
-install: build
-       dh_testdir
-       dh_testroot
-       dh_clean -k
-       dh_installdirs
-
-       # Add here commands to install the package into debian/deptrack
-       $(MAKE) install prefix=$(CURDIR)/debian/deptrack/usr
-
-
-# Build architecture-independent files here.
-binary-indep: build install
-       dh_testdir
-       dh_testroot
-       dh_installdocs
-       dh_installexamples
-       dh_installman
-       dh_installchangelogs ChangeLog 
-       dh_compress
-       dh_fixperms
-       dh_installdeb
-       dh_perl
-       dh_gencontrol
-       dh_md5sums
-       dh_builddeb
-
-binary: binary-indep 
-.PHONY: build clean binary-indep binary install 
+include /usr/share/cdbs/1/rules/debhelper.mk
+include /usr/share/cdbs/1/class/autotools.mk