cleanup properly on uninstall
[old-projects.git] / depview / debian / rules
CommitLineData
a91b29e4
JL
1#!/usr/bin/make -f
2# Sample debian/rules that uses debhelper.
3# GNU copyright 1997 to 1999 by Joey Hess.
4
5# Uncomment this to turn on verbose mode.
6#export DH_VERBOSE=1
7
8# This is the debhelper compatibility version to use.
9export DH_COMPAT=4
10
f835b396 11destdir=debian/depview/var/www/depview
a91b29e4
JL
12
13CFLAGS = -Wall -g
14
15ifneq (,$(findstring noopt,$(DEB_BUILD_OPTIONS)))
16 CFLAGS += -O0
17else
18 CFLAGS += -O2
19endif
20ifeq (,$(findstring nostrip,$(DEB_BUILD_OPTIONS)))
21 INSTALL_PROGRAM += -s
22endif
23
24configure: configure-stamp
25configure-stamp:
26 dh_testdir
27 # Add here commands to configure the package.
28
29 touch configure-stamp
30
31
32build: build-stamp
33
34build-stamp: configure-stamp
35 dh_testdir
36
37 # Add here commands to compile the package.
38 #$(MAKE)
39 #/usr/bin/docbook-to-man debian/depview.sgml > depview.1
40 touch build-stamp
41
42clean:
43 dh_testdir
44 dh_testroot
45 rm -f build-stamp configure-stamp
46
47 # Add here commands to clean up after the build process.
f835b396 48
a91b29e4
JL
49 dh_clean
50
51install: build
52 dh_testdir
53 dh_testroot
54 dh_clean -k
55 dh_installdirs
56
57 # Add here commands to install the package into debian/depview.
f835b396
JL
58 cp index.php file.php list.php depview.css $(destdir)
59 cp include/header.inc.php include/footer.inc.php $(destdir)/include
a91b29e4
JL
60
61# Build architecture-independent files here.
62binary-indep: build install
63 dh_testdir
64 dh_testroot
65 dh_installdebconf
66 dh_installdocs
67 dh_installexamples
a91b29e4
JL
68# dh_installlogrotate
69# dh_installemacsen
a91b29e4
JL
70# dh_installcron
71# dh_installman
72# dh_installinfo
a91b29e4
JL
73 dh_installchangelogs ChangeLog
74# dh_link
75# dh_strip
76 dh_compress
77 dh_fixperms
a91b29e4
JL
78 dh_installdeb
79# dh_perl
80 dh_gencontrol
81 dh_md5sums
82 dh_builddeb
83
84binary: binary-indep
85.PHONY: build clean binary-indep binary install configure